Results 1 to 6 of 6

Thread: LHD MK2 16V with Factory Digifiz has lost its Odometer Memory.

  1. #1
    Forum User
    Join Date
    Apr 2014
    Posts
    13
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default LHD MK2 16V with Factory Digifiz has lost its Odometer Memory.

    Hey guys,

    Have not posted for many years, (quite a few years of trouble free motoring...)

    I have been Daily driving my 16V MK2 (Re Fitted with MK3 ABF Engine and Injection. for the last few weeks.

    Any who since rebuilding the car 5 years ago things have been smooth Sailing, I have only traveled around 12500km in this time.

    This morning When I had left home my Odometer was around 12,600km.

    During the day I was running some errands when I looked down and Noticed my Odometer had reset to 0, I have had this occur before hand however after cycling the key the Mileage came back.

    When I had rebuilt the car some time ago, I bought a NOS Digifiz Gauge from Ebay.nl because the Digifiz in the Car had some pretty awful scratches and issues occurring. (This is why the Mileage started from 0 again 5 years ago....)

    Any way has any one had this occur before, have I ended up with a dead eeprom or something on that Circuit board? every time I try to Phrase and Google this situation, I just find posts about Digifiz clusters hitting their max mileage threshold blah blah.

    Thank you in advance!

  2. #2
    Forum User
    Join Date
    Apr 2014
    Posts
    13
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Never mind looks like I found my Answer hidding in the How to reprogram the Digifiz Mileage Thread.

    I love this forum, it truly is a fountain of information..

    Probable dead NMC9307EN now to try find one...

  3. #3
    Paid Member Trev16v's Avatar
    Join Date
    Oct 2003
    Location
    Oxfordshireland
    Posts
    13,005
    Thanks
    367
    Thanked 462 Times in 280 Posts

    Default

    Glad the thread was helpful

    Those EEPROMs do indeed fail; I had to replace one the other week.

    I can't currently advise on a source of new ones, but I've heard of people getting hold of them.


    MSDroid - the Android dashboard, logging and tuning application for Megasquirt ECUs


  4. #4
    Forum User
    Join Date
    Apr 2014
    Posts
    13
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    I may have found one... but then again i could be wrong

    https://m.ebay.com/itm/eBayISAPI.dll...83&_mwBanner=1

  5. #5
    Paid Member Trev16v's Avatar
    Join Date
    Oct 2003
    Location
    Oxfordshireland
    Posts
    13,005
    Thanks
    367
    Thanked 462 Times in 280 Posts

    Default

    Ah, that's the one


    MSDroid - the Android dashboard, logging and tuning application for Megasquirt ECUs


  6. #6
    Forum User
    Join Date
    Apr 2014
    Posts
    13
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Brilliant.

    I will PM you trev16v

    I cant seem to find a suitable EEPROM flasher that will do the job to correct the mileage.

    In a funny turn of events the cluster has started recording the KMs again but has started from 0 again...

    Frustrating :-(

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •